Sunday 16th October 2022

Core Service Service Outage

The service is currently non-operational. Our engineering team is inspecting with top-most priority. More updates will be posted here.

UPDATE - We've identified the root cause, and we are working on a solution.

FIXED - It appears we have resolved the issue. Our team is monitoring the situation closely, with readiness to act.