Thursday 24th February 2022

Core Service Degraded performance on optimizations

We received reports of slow optimizations. Optimizations are generally working but may produce results with a delay. Our engineering team is looking into the issue. More updates will be posted on this page.

UPDATE: Our engineers have identified the source of the issue. The team is working on a solution.

UPDATE: The issue has been alleviated, and the service is fully operational. We are monitoring our systems.