Sunday 7th November 2021

Core Service Service Instability in Core Service

We've identified service instability in three of our servers. Our team is investigating the systems.

UPDATE - Issue identified, and we are working on a fix.

UPDATE 2 - The issue has been resolved