Thursday 7th October 2021

Website Issue with subscriptions

FIXED - We can see no reoccurrence of the issue after we applied the fix. Case closed.


UPDATE - We have released a fix and we are monitoring the subscription system.


We've identified an issue with our subscription system. We've found the root cause, and our team is working on a fix. We will post an update here once resolved.